بروزرسانی خودکار افزونه ها و قالب ها در وردپرس 5.5

بروزرسانی خودکار وردپرس

وردپرس در نسخه 5.5 خود قرار است قابلت به روزرسانی خودکار در بخش افزونه ها و قالب هایش را در خود جای دهد. این ویژگی در سال 2019 شروع و در نقشه راه 2020 وردپرس نیز دیده می شود.

افزونه به روزرسان خودکار وردپرس، برای تست بتا در مخزن وردپرس در دسترس قرار گرفته است. این افزونه در حال حاضر بر روی php 7.2 و جدیدتر قابلیت فعالیت دارد که البته در صورتی که به عنوان یک افزونه ویژه در نظر گرفته شده می بایست با حداقل ورژن PHP که خود وردپرس قادر است با آن کار کند یعنی 5.6 نیز همخوانی داشته باشد.

این ویژگی خیلی زودتر از این ها می بایست در وردپرس قرار می گرفت و این درحالی است که از سال 2015 کاربران چنین ویژگی ای را درخواست کرده بودند. البته افزونه هایی نظیر جت پک نیز جبران کمبود این افزونه را داشته اند اما حال زمان آن رسیده است که این ویژگی در هسته اصلی وردپرس نهادینه شده و در دسترس کلیه کاربران وردپرس قرار بگیرد.

یکی از اهداف اصلی این پروژه این است که یک رابط کاربری در محیط مدیریت وردپرس در اختیار کاربر قرار بدهد و مدیر سایت بتواند تصمیم بگیرد که آپدیت های خودکار به چه صورت انجام بپذیرند. کاربران قادرند تا به روزرسانی خودکار هر افزونه را به صورت جداگانه متوقف کنند که به نظر می رسد تنظیم بسیار خوب و کاربردی ای است.

همچنین ارسال ایمیل های اطلاعیه به مدیر سایت که شرح حالی از وضعیت آپدیت های خودکار به وی ارائه می دهند نیز در اهداف این پروژه دیده شده است.

ضمن این که همانند سایر ویژگی های اصلی وردپرس، ابزارهایی نیز در اختیار برنامه نویسان جهت کنترل آپدیت ها نیز قرار خواهد گرفت.

دانلود افزونه آپدیت خودکار وردپرس

ریپوزیتوری گیت هاب مربوط به این افزونه

Total
0
Shares
دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.

پست قبلی
wordpress-lazy-load

وردپرس 5.4 قابلیت lazy-loading را برای کلیه تصاویر فعال می کند

پست بعدی
گوتنبرگ وردپرس

گوتنبرگ نسخه 7.6 شامل لیست راهنمای چرخشی و بلاک های کاملتر

پست های مرتبط